Schreiben Berechtigungsprobleme mit den folgenden Verzeichnissen / Dateien Elementor Upload-Verzeichnis

stimmen
0

Jedesmal , wenn ich möchte aktualisiert eine bestimmte Seite auf meiner Wordpress - Seite der Seite wird eingefroren und nicht lassen Sie mich den Builder verwenden. Auf Wordpress - Dashboard ich diese Meldung: Schreiben Berechtigungsprobleme mit den folgenden Verzeichnissen / Dateien Elementor Upload - Verzeichnis.

Wenn ich die Fehlerprotokolle überprüfen finde ich die folgenden:

`[error] 14605#14605: *52603 FastCGI sent in stderr: PHP message: PHP Warning:
  file_put_contents(/var/www/corvettes2.performancecorvettes.com/public/wp-content/uploads/elementor/css/post-701.css): 
failed to open stream: 
Permission denied in /var/www/corvettes2.performancecorvettes.com/public/
wp-content/plugins/elementor/core/files/base.php` 

Was ich bisher versucht:

  1. Ich habe stellen Sie sicher , ich habe festgelegt , die richtigen Berechtigungen für Ordner und Dateien (755 Ordner und Unterordner, 644 Dateien)
  2. Ich ändern Sie die max_input_vars bis 1000 auf der .htaccess - Datei
  3. Ich habe die nginx conf überprüfen - Datei sicher nichts ungerade zu machen (noch ich nichts falsch finden):

;

 user  nginx;
 worker_processes  auto;
 worker_rlimit_nofile 20000;
 error_log  /var/log/nginx/error.log warn;
 pid        /var/run/nginx.pid;


  events {
  worker_connections  4096;
  multi_accept on;
  use epoll;
}


 http {
    include       /etc/nginx/mime.types;
    default_type  application/octet-stream;

log_format  main  '$remote_addr - $remote_user [$time_local] $request '
                  '$status $body_bytes_sent $http_referer '
                  '$http_user_agent $http_x_forwarded_for';

access_log  /var/log/nginx/access.log  main;

sendfile on;
tcp_nopush on;
tcp_nodelay on;

keepalive_requests 100000;
keepalive_timeout  5;
send_timeout 10;

gzip  on;
gzip_http_version 1.0;
gzip_comp_level 2;
gzip_proxied any;
gzip_vary off;
gzip_types text/plain text/css text/xml application/xml application/rss+xml application/atom+xml application/x-font-ttf application/font-woff application/vnd.ms-fontobject application/javascript application/json application/x-javascript application/x-httpd-php application/x-httpd-fastphp application/x-httpd-eruby image/svg+xml text/javascript text/mathml;
gzip_min_length  1000;
gzip_disable     MSIE [1-6]\.;

include /etc/nginx/conf.d/*.conf;
include /etc/nginx/sites-enabled/*;
client_max_body_size 20M;
}
Veröffentlicht am 13/02/2020 um 22:06
quelle vom benutzer
In anderen Sprachen...                            


1 antworten

stimmen
0

Überprüfen Sie das Eigentum an dem Upload-Verzeichnis und es ist Dateien. Höchstwahrscheinlich werden sie von root oder einem anderen Benutzer gehört. Wenn ja, verwenden Sie chmod es den nginx Benutzer zu ändern.

Beantwortet am 14/02/2020 um 00:31
quelle vom benutzer

Cookies help us deliver our services. By using our services, you agree to our use of cookies. Learn more