HAProxy / Docker: 502 Bad Gateway beim Treffen Docker Behälter läuft Flask / app Reagieren

stimmen
0

Ich versuche, für einfache Entwicklung / Zusammenarbeit eine Kolben / React Webapplikation Dockerize, aber mit Fragen eine richtige Antwort von der Anwendung zu bekommen. Ich bin in der Lage, das Bild aufgebaut und Flask-Server in einem Behälter zu erhalten begonnen, aber Probleme mit tatsächlich zu treffen.

Wir verwenden HAProxy, um vorwärts Anfragen, und die Dinge gut funktionieren, wenn ich die Proxy und Web-Server lokal ausgeführt. Das Problem wurde immer Docker in den Mix. Ich glaube, es muss ein Port-Mapping-Problem sein, aber ich bin aus Ideen und ich fühle mich Schlüssel HAProxy / Docker Feinheiten fehlen. Die PROXY.CFG Datei sieht wie folgt aus (mit fremden Rechner nicht im Lieferumfang enthalten):

global
 maxconn 4096
 pidfile ~/tmp/haproxy.pid

defaults
 log global
 log 127.0.0.1 local0
 log 127.0.0.1 local1 notice
 mode http
 timeout connect 300000
 timeout client 300000
 timeout server 300000
 maxconn 2000
 option redispatch
 retries 3
 option httpclose
 option httplog
 option forwardfor
 option httpchk HEAD / HTTP/1.0


frontend dev
   bind *:8080 ssl crt ./proxy.pem

    acl allow_web path_beg /app/

    use_backend be_web if allow_web

backend be_web
 balance roundrobin
 server web_5000 localhost:5000

Dockerfile:

FROM node:10.6.0

RUN apt-get update
RUN apt-get install -y python-pip python-dev build-essential 

WORKDIR /usr/src/app

COPY ./package.json .
RUN npm install
COPY . .
RUN pip install -e ./server

CMD [npm, start]

Docker-compose.yml:

version: 3

services:
    userportal:
        build: .
        volumes:
            - /usr/src/app/node_modules
            - .:/usr/src/app
        ports:
            - 5000:5000

Der Kolben Server bindet an Port 5000 somit die Abbildung. Ich habe versucht , für den Container IP - Adresse ersetzt wird localhost(zB 172.19.0.2:5000) , aber gleiches Ergebnis.

Hinweis HAProxy wird in einem eigenen Terminal läuft und ist nicht in einem Container.

Veröffentlicht am 13/02/2020 um 21:59
quelle vom benutzer
In anderen Sprachen...                            


1 antworten

stimmen
0

Sie sollten Ihre Container IP im Voraus

docker inspect -f '{{range .NetworkSettings.Networks}}{{.IPAddress}}{{end}}' container_name_or_id

Irgendwann, wenn Sie es wird leichter machen es in Docker compose zu avoir Netzwerkprobleme verwenden HAProxy wollen

Wenn Sie nicht wollen, können Sie versuchen: haproxy.conf

global
  maxconn 4096
  pidfile ~/tmp/haproxy.pid

defaults
  log global
  log 127.0.0.1 local0
  log 127.0.0.1 local1 notice
  mode http
  timeout connect 300000
  timeout client 300000
  timeout server 300000
  maxconn 2000
  option redispatch
  retries 3
  option httpclose
  option httplog
  option forwardfor
  option httpchk HEAD / HTTP/1.0


frontend dev
  bind 0.0.0.0:8080 ssl crt ./proxy.pem   // <-- change wildcard with 0.0.0.0
  acl allow_web path_beg /app/
  use_backend be_web if allow_web
  default_backend be_web                  // <-- add this line

backend be_web
  balance roundrobin
  mode http
  option forwardfor                       // <-- add this line
  option httpchk GET / HTTP/1.1           // <-- add this line
  server web_5000 userportal_1:5000 check // <-- change localhost to the nane of running container "userportal_1" or the IP if you get it

Dockerfile:

FROM node:10.6.0

RUN apt-get update
RUN apt-get install -y python-pip python-dev build-essential

WORKDIR /usr/src/app

COPY ./package.json .
RUN npm install
COPY . .
RUN pip install -e ./server

EXPOSE 5000 // <-- add this ine

CMD ["npm", "start"]

Docker-compose.yml

version: "3"

services:
  userportal:
    build: .
    volumes:
      - /usr/src/app/node_modules
      - .:/usr/src/app
    ports:
      - "5000:5000"

Versuchen Sie, Ihre HAProxy in Ihrem Docker-compose.yml einschließen wird eine Menge helfen

Beantwortet am 13/02/2020 um 22:56
quelle vom benutzer

Cookies help us deliver our services. By using our services, you agree to our use of cookies. Learn more