Kann nicht einen vorhandenen Container mit Podman starten

stimmen
0

Ich bin mit Podman auf Ubuntu 18.04. Ich bin nicht in der Lage, einen Behälter nach dem Anhalten ihn zu starten.

Ich betreibe den Behälter mit:

podman run -d -p 8081:8081 --name nexus -v /opt/nexus-data:/nexus-data sonatype/nexus3

Und es startet ok. Wenn ich laufen:

podman container stop nexus
podman container start nexus

Ich erhalte eine Fehlermeldung: Fehler: nicht in der Lage Container nexus zu starten: Container (keine Protokolle von conmon) failed create: EOF

Wenn mit Debug-Protokollierung laufen sehe ich dies in der Ausgabe:

DEBU [0000] Initializing Ereignis Backend journald
DEBU [0000] Laufzeit mit / usr / lib / cri-o-Runc / sbin / Runc Warnen [0000] Fehler bei der Initialisierung konfiguriert OCI Laufzeit CRUN: keine gültige ausführbare gefunden für OCI Laufzeit CRUN: ungültiges Argument .... DEBU [0000] post Container 419f6576ff23328c6445526058c9988aa27a4b69605348230fa26246a522c726 ERRO [0000] nicht in der Lage Container nexus zu starten: Container erstellen fehlgeschlagen (keine Protokolle von conmon): EOF

Das Quellbild ist: docker.io/sonatype/nexus3

Ich bin mir nicht sicher, was das „ungültig Argument“ in den Protokollen Mitteln. Benötige ich ein weiteres Argument zu übergeben?

Veröffentlicht am 14/01/2020 um 00:02
quelle vom benutzer
In anderen Sprachen...                            


2 antworten

stimmen
0

scheint es mit der neuesten Version von Problem zu sein conmonPaket von Projekt Atomic PPA (v 2.0.3).

Ich hatte das gleiche Problem , und ich installierte eine niedrigere Version von conmonPaket (v 2.0.0) aus, https://launchpad.net/ubuntu/+archive/primary/+files/conmon_2.0.0-1_amd64.deb

Dies ist ein Paket für EOAN gebaut. Aber es funktionierte auf meiner Bionic Umgebung und ich bin in der Lage wieder meine Container zu starten.

Beantwortet am 14/01/2020 um 09:36
quelle vom benutzer

stimmen
0

Wie @Loki Arya erwähnt, verursacht wurde ein Fehler in dem gemeinsamen Paket das Problem. Da Podman für Unbuntu nicht mehr bei projectatomic ppa gehostet wird, werden die Updates nach Version 1.6.2, die den Fehler behoben waren nicht vorhanden.

Das Projekt Atomic ppa und alle zugehörigen Pakete Nach dem Entfernen ich neu installiert Podman für Ubuntu von seinem neuen Repositoryposition hier

Ich habe getestet Podman (1.7) und es funktioniert super, einschließlich dem Startbefehl

Beantwortet am 18/01/2020 um 19:22
quelle vom benutzer

Cookies help us deliver our services. By using our services, you agree to our use of cookies. Learn more