Ich versuche Android Studio zu laufen, aber Klasse syn Fehler haben. Es gibt fünf Fehler der Abhängigkeit, Debugging. Was ist die Lösung

stimmen
0

Ich bin mit Android 3.1.4 und Grad Version Ich habe versucht, 4.4 4.5 4.10 und die neuesten eine 5.6.2 aber keiner von ihnen scheinen zu helfen. Die neueste Version zeigt einige andere Fehler though. Was ist die Lösung?

Veröffentlicht am 09/10/2019 um 18:49
quelle vom benutzer
In anderen Sprachen...                            


1 antworten

stimmen
0

Für min api 21 und 28 zielen, habe ich die folgenden Einstellungen mein build.gradle (Modul: App-Datei).

apply plugin: 'com.android.application'

android {
compileSdkVersion 28
defaultConfig {
    applicationId "com.example.yourprojectname"
    minSdkVersion 21
    targetSdkVersion 28
    versionCode 1
    versionName "1.0"
    testInstrumentationRunner "android.support.test.runner.AndroidJUnitRunner"
    vectorDrawables.useSupportLibrary = true
}
buildTypes {
    release {
        minifyEnabled false
        proguardFiles getDefaultProguardFile('proguard-android-optimize.txt'), 
'proguard-rules.pro'
    }
 }
 }

 dependencies {
     implementation fileTree(dir: 'libs', include: ['*.jar'])
     implementation 'com.android.support:appcompat-v7:28.+'
     implementation 'com.android.support:support-v4:28.+'
     implementation 'com.android.support:design:28.+'
     implementation 'com.android.support.constraint:constraint-layout:1.0.2'
     testImplementation 'junit:junit:4.12'
     androidTestImplementation 'com.android.support.test:runner:1.0.1'
     androidTestImplementation 'com.android.support.test.espresso:espresso- 
     core:3.0.1'

}

Wenn Sie eine andere min api Ebene haben, ändern Sie die Eigenschaft minSdkVersion auf Ihre api und sync wieder an. Hoffe das hilft.

Beantwortet am 11/10/2019 um 17:07
quelle vom benutzer

Cookies help us deliver our services. By using our services, you agree to our use of cookies. Learn more