Installieren von gettext in den Fenstern: Kann nicht msguniq finden. Stellen Sie sicher, dass Sie GNU haben gettext Tools 0.15 oder höher installiert

stimmen
0

Ich folgte dem Lehrer der Installation gettext an Fenstern und wenn ich xgettext --Version in meinem Kommandozeile ein, sagt, dass es installiert ist. aber wenn ich will, diesen Befehl auszuführen: Python manage.py makemessages -l „fa“ in meinem Projekt sagt, es kann nicht msguniq finden. Vergewissern Sie sich, GNU gettext Tools 0.15 oder höher installiert ist. Ich habe versucht, so hart, aber es scheint, gibt es keine gute Antworten gibt,

Veröffentlicht am 19/12/2018 um 14:07
quelle vom benutzer
In anderen Sprachen...                            


1 antworten

stimmen
1

In Windows müssen Sie nur herunterladen:

gettext-tools-xx.zip
gettext-runtime-xx.zip

von hier: Geben Sie hier Linkbeschreibung

und dann müssen Sie sie entpacken und kopieren Sie alle in Binärordner beider Dateien in C: \ Programme \ gettext-utils \ bin und dann müssen Sie gehen Panel-> System steuern -> Erweitert -> Umgebungsvariablen und fügen Sie diese Pfad: C: \ Programme \ gettext-utils \ sind Pfadvariablen. Hinweis:

  • xx ist die Version, die Sie herunterladen möchten, wenn Sie 18-Version herunterladen erhalten Sie eine Fehlermeldung erhalten, dass einige DLL-Datei fehlt, schlage ich vor Version 17 zum Download
  • Dieser Ordner: gettext-utils \ ist nicht existiert und Sie müssen es schaffen
  • resteart Ihren PC, bevor Sie gettext verwenden
Beantwortet am 19/12/2018 um 14:24
quelle vom benutzer

Cookies help us deliver our services. By using our services, you agree to our use of cookies. Learn more