Installieren Rails ERROR: konnte nicht Schienen lokal oder in einem Repository finden

stimmen
2

Ich habe Suche auf diesen einen für eine Lösung rund um das Internet wurden Stossen ... ohne Glück .. Ich bin neu auf Schienen ... Wenn jemand eine Idee hat, würde ich gerne hören. Viel zu schätzen!

Ich betrete:

LW:src liamwright$ sudo gem install rails --include-dependencies

Und bekomme:

INFO:  `gem install -y` is now default and will be removed
INFO:  use --ignore-dependencies to install only the gems you list
Bulk updating Gem source index for: http://gems.rubyforge.org
ERROR:  could not find rails locally or in a repository

Ich renne:

ruby 1.8.6 (2008-08-11 patchlevel 287) [universal-darwin9.0]
Mac OS X 10.5.8

Ich habe auch versucht:

gem sources -r gems.rubyonrails.org 

Und bekomme:

source gems.rubyonrails.org not present in cache
Veröffentlicht am 30/12/2009 um 01:53
quelle vom benutzer
In anderen Sprachen...                            


4 antworten

stimmen
2

Vielleicht möchten sicherstellen, dass Sie die neuesten rubygems haben:

sudo gem install rubygems-update
sudo gem update --system

Dann:

sudo gem install rails
Beantwortet am 30/12/2009 um 02:02
quelle vom benutzer

stimmen
2

Nur um zu überprüfen ...

... versuchen eine zu tun , sudo gem update --systembevor Rails , um sicherzustellen , Sie haben die neuesten RubyGems installiert zu installieren?

EDIT: Eigentlich, wenn Ihr RubyGems installieren wirklich alt ist, müssen Sie möglicherweise die folgen wechselnden Richtungen auf Gemcutter .

Beantwortet am 30/12/2009 um 02:04
quelle vom benutzer

stimmen
1

Ich kam in dieser Lösung auf Albertux‘blox . Das Ausführen dieses Skript wird es beheben (Er arbeitete für mich perfekt auf einer Ubuntu 9.10 Maschine):

#!/bin/bash
#(download the latest on http://rubyforge.org/frs/?group_id=126)
wget http://rubyforge.org/frs/download.php/43984/rubygems-update-1.3.0.gem
sudo gem install rubygems-update-1.3.0.gem
sudo update_rubygems
# now this work:
sudo gem update --system
echo "done."
Beantwortet am 02/01/2010 um 14:25
quelle vom benutzer

stimmen
0

Ich habe gerade das gleiche Problem habe versucht rubygems von 1.2.0 auf 1.3.7 zu aktualisieren.

Setp-1) Also habe ich nur rubygems-update-1.3.7.gem heruntergeladen http://rubyforge.org/frs/?group_id=126

Setp-2) gem install rubygems-update-1.3.7.gem

SETP-3) update_rubygems

und es für mich arbeiten.

Beantwortet am 29/11/2010 um 04:55
quelle vom benutzer

Cookies help us deliver our services. By using our services, you agree to our use of cookies. Learn more