versuchen hs-ffmpeg Haskell-Paket installiert werden kann libdc1394 finden

stimmen
1

tun „Kabale installieren hs-ffmpeg“ versagt wie folgt aus:

checking for faacEncGetVersion in -lfaac... no
checking for zlibVersion in -lz... yes
checking for libdc1394... configure: error: Package requirements (libdc1394) were not met:

No package 'libdc1394' found

Consider adjusting the PKG_CONFIG_PATH environment variable if you
installed software in a non-standard prefix.

Alternatively, you may set the environment variables libdc1394_CFLAGS
and libdc1394_LIBS to avoid the need to call pkg-config.
See the pkg-config man page for more details.

cabal: Error: some packages failed to install:
hs-ffmpeg-0.3.4 failed during the configure step. The exception was:
exit: ExitFailure 1

Ich habe libdc1394-22 und libdc1394-22-dev installiert Ubuntu 9.10 Karmic Koala. Ich denke, dass die Abhängigkeit aktualisiert werden muss, um das neue Paket zu reflektieren, die libdc1394 super, aber ich bin nicht sicher, wie das zu tun.

Veröffentlicht am 30/12/2009 um 00:11
quelle vom benutzer
In anderen Sprachen...                            


1 antworten

stimmen
3

hs-FFmpegs configureSkript für eine suchen libdc1394.pc. Aus irgendeinem Grund Schiffe Ubuntu ein libdc1394-2.pcstatt.

Bearbeiten hs-FFmpegs configure.acden „richtigen“ Namen zu verwenden , und dann laufen autoreconf, und es sollte funktionieren.

So etwas mkdir -p ~/.pc; ln -s /usr/lib/pkgconfig/libdc1394-2.pc ~/.pc/libdc1394.pc; export PKG_CONFIG_PATH+=:~/.pckann auch funktionieren.

Beantwortet am 30/12/2009 um 02:40
quelle vom benutzer

Cookies help us deliver our services. By using our services, you agree to our use of cookies. Learn more